Saltstack [SOLVED]: Salt installation in rhel 5.4

Saltstack [SOLVED]: Salt installation in rhel 5.4

Home Forums Automation Tools Saltstack Tutorials Saltstack [SOLVED]: Salt installation in rhel 5.4

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #189123

    Cloudy Point
    Keymaster

    QuestionQuestion

    I am trying to install salt-2016.11.3-2.el5.noarch.rpm in rhel5. For that I compiled python 2.6

    [root@localhost bin]# ls -lrt python*
    -rwxr-xr-x 1 root root    8304 Jun 11  2009 python2.4
    -rwxr-xr-x 2 root root 5733122 Sep 11 11:52 python2.6
    -rwxr-xr-x 2 root root 5733122 Sep 11 11:52 python
    lrwxrwxrwx 1 root root      16 Sep 11 11:53 python-config -> python2.6-config
    -rwxr-xr-x 1 root root    1418 Sep 11 11:53 python2.6-config
    

    After I tried to install salt-minion which is showing this deps.

    [root@localhost minion]# rpm -ivh salt-2016.11.3-2.el5.noarch.rpm
    warning: salt-2016.11.3-2.el5.noarch.rpm: Header V3 RSA/SHA1 signature: NOKEY, key ID 42e589e9
    error: Failed dependencies:
            **/usr/bin/python2.6 is needed by salt-2016.11.3-2.el5.noarch**
            python26-PyYAML is needed by salt-2016.11.3-2.el5.noarch
            python26-crypto >= 2.6.1 is needed by salt-2016.11.3-2.el5.noarch
            python26-jinja2 is needed by salt-2016.11.3-2.el5.noarch
            python26-msgpack > 0.3 is needed by salt-2016.11.3-2.el5.noarch
            python26-requests >= 1.0.0 is needed by salt-2016.11.3-2.el5.noarch
            python26-six is needed by salt-2016.11.3-2.el5.noarch
            python26-tornado >= 4.2.1 is needed by salt-2016.11.3-2.el5.noarch
            yum-utils is needed by salt-2016.11.3-2.el5.noarch
    

    I already installed python and its available in PATH. Still why its showing that deps. Anyone faced the same issue??? Any suggestions are welcome.

    Note:

    the main issue is

    /usr/bin/python2.6 is needed by salt-2016.11.3-2.el5.noarch

    Why python is showing in the dependency list which is already installed???

    #189124

    Cloudy Point
    Keymaster

    Accepted AnswerAnswer

    I guess you installed python 2.6 manually without creating a rpm package. The dependencies you see are those specified in the saltstack rpm. They are checked against the installed rpms, not the actual filesystem. If you didn’t install python 2.6 as a rpm, it’s normal that you have these dependencies errors.

    Install rpm without dependencies

    As a solution, you may try to install the rpm without dependencies checking. That should be something like: rpm -ivh --nodeps but you’ll most likely miss some other dependencies (python modules).

    Install manually

    Or you can choose to install saltstack manually, with the sources and installation script. And you’ll miss other dependencies too but you’ll have to find them yourselves. Or rely on the documentation: https://docs.saltstack.com/en/latest/topics/installation/index.html#dependencies

    All rpm installation

    Or you can install all needed rpms. Most are available in the SaltStack repository: https://repo.saltstack.com/yum/redhat/5Server/x86_64/latest/. You’ll need at least:

    • python26
    • python26-ordereddict
    • python26-msgpackX
    • python26-six

    And a few others like python26-zmq, python26-tornado, libyaml, python26-jinja2 and so on. Once you have all dependencies packages, you should be good to install them all at once. Some are not required by the saltstack package and you will run into errors until you get those dependencies.

    Source: https://stackoverflow.com/questions/46149435/salt-installation-in-rhel-5-4
    Author: Christophe Drevet-Droguet
    Creative Commons License
    This work is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 International License.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.